Successful launch ZENLIX on PHP 7


We have completed successful testing of version 3.0.1 applications to the new version of PHP 7. This is made possible thanks to the used framework Laravel 5.1.


As an operating system, we used Ubuntu 14.04, but we also want to note that since 04.21.2016 available version of Ubuntu 16.04, which by default will contain PHP7.

We decided just to test the system without the use of Apache and VESTA panel.

Below are brief instructions for installing the necessary software to use the system:

sudo apt-get update
sudo apt-get install build-essential
sudo apt-get install nginx
sudo apt-get install mysql-server
sudo mysql_install_db
sudo mysql_secure_installation
sudo add-apt-repository ppa:ondrej/php
sudo apt-get install -y language-pack-en-base
sudo LC_ALL=en_US.UTF-8 add-apt-repository ppa:ondrej/php
sudo apt-get install php7.0
sudo apt-get install php7.0-mysql php7.0-fpm mcrypt php7.0-mcrypt php7.0-zip php7.0-curl php7.0-gd php7.0-imap php7.0-ldap php7.0-mbstring

These libraries are required to use ZENLIX v.3.x on PHP7.


php7,php-fpm,nginx